Elevated latency and error rates for AML screening checks

Incident Report for Vouched

Resolved

This incident has been resolved.
Posted Aug 01, 2026 - 06:31 PDT

Investigating

We are currently investigating an issue with a data provider.
Posted Aug 01, 2026 - 00:00 PDT
This incident affected: API.