We are investigating issues where invite links are not loading for customers.
Incident Report for Vouched
Resolved
We identified the root cause and implemented a fix.
Posted Sep 27, 2023 - 14:10 PDT
Investigating
We are looking into issues where invites are not properly loading for customers.
Posted Sep 27, 2023 - 14:01 PDT
This incident affected: API and Management Portal.