ITIN Outage

Incident Report for Vouched

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 13:13 PST

Investigating

We are currently investigating an issue affecting ITIN requests. Our team is actively working to identify the cause and restore normal service. Updates will be provided as we learn more.
Posted Nov 25, 2025 - 11:45 PST
This incident affected: API.