We are investigating issues with the ecbsv SSN verification API
Incident Report for Vouched
Resolved
An issue with our downstream provider has been resolved.
Posted Jun 21, 2023 - 08:44 PDT
Investigating
We are investigating increases latency and error rates with the SSN verification API documented here https://docs.vouched.id/reference/ecbsv_ssnjob-1.

All other API endpoints are functioning normally.
Posted Jun 20, 2023 - 21:00 PDT
This incident affected: API.