Degradation in processing drivers license verification for California
Incident Report for Vouched
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 13:19 PST
Investigating
We have identified an issue causing verification of California drivers license to be delayed. We are working on a resolution and will report back with updates.
Posted Nov 02, 2023 - 13:49 PDT
This incident affected: API and JS Plugin.