Our downstream provider for AAMVA and DLV is experiencing issues causing delays in processing requests.
Incident Report for Vouched
Resolved
This incident has been resolved.
Posted Aug 09, 2023 - 16:07 PDT
Identified
Impact to customers are that DLV and AAMVA portions of IDV will be delayed.
Posted Aug 09, 2023 - 13:12 PDT
This incident affected: API and JS Plugin.